30
My World 3 and the My World 3 manual are copyright Dial Solutions 1999 - 2000
More info from www.dialsolutions.com
My World 3 for Windows TM


Text Only Manual



Contents

Introduction			2

Example screens		3

Browser Menu		5

Editor Menu			11

Editor Tutorial		30

FAQs				33



















© Dial Solutions 2000


Introduction 

Welcome to My World 3 for Windows TM 

My World was originally developed by Derbyshire's IT support team. It has become a popular, award winning educational software resource. Its concept is simple, but it has proved to be one of the most widely used programs in UK education. 

My World 3 screens can contain pictures, text, animation, video and sound. These can be picked up, moved, dropped and deleted. Text can be added and edited. 

The program is very simple to learn and use, yet is powerful enough to be a most effective learning tool. My World 3 can be used in many ways and across the whole school curriculum. 

Installation

My World 3 is supplied on a CD ROM. 

System Requirements 
- Windows 95 or later 
- VGA monitor 
-	CD ROM drive 
-	
Installation 
Insert the My World 3 CD ROM into the CD ROM drive. 
Inserting the CD ROM into the drive should cause the autoplay dialogue to appear. If you have not installed My World 3 before, you will be presented with an 'Install' option from this dialog box. Click this and follow the onscreen instructions. 

You can also install My World 3 by clicking on the Start button on the taskbar. Click 'Run...', type D:\SETUP' (where D is the letter that designates your CD ROM drive) Then click 'OK'. Follow the onscreen instructions. 

Acknowledgements

The My World name is © Derbyshire County Council 

My World 3 for Windows TM is copyright © Dial Solutions 1999 

Neither the whole nor any part of the information contained in this Guide may be adapted or reproduced in any material form except with prior written approval of Dial Solutions. 

All trademarks acknowledged. 

The software is supplied 'as is‘, Dial Solutions makes no warranty, whether expressed or implied, of the merchantability of the Software or its fitness for any particular purpose. In no circumstances will Dial Solutions be liable for any damage, loss of profits, good-will or for any indirect or consequential loss arising out of your use of the Software, or inability to use the Software, even if Dial Solutions have been advised of the possibility of such loss. 



Example Screens

My World 3 is supplied with a set of Example Screens: 

Blocks 1 and 2 - Build your own "3D" block patterns. 

Body - Identify and name the parts of the body. 

Cafe - Choose a meal. Make up the bill. 

Chart Make block graphs and pictograms. 

City Design your own city. 

Dinosaur - Assemble the dinosaur bones. 

Egypt - Build an ancient Egyptian frieze. 

Face - Name the parts of the face. 

Find Ted - Find the elusive bears. Add your own. 

Fishtank - Fill the tank with fish and coral. 

Forecast - Make a forecast chart. 

Goldilocks - Help Goldilocks explore the house of the bears. 

Hundred Square - Explore number patterns. 

Jigsaw - Complete the jigsaw. Solve the puzzle. 

Matching - Match words and pictures. Put them in alphabet order. 

Number Bonds - Bonds to 10, 20, 50 and 100 

Number Sentences - Build your own number sentences. 

Phrase Book - Useful phrases in five languages 

Place Value - Use words and numbers to show place value 

Sequencing - Put words and pictures into chronological order 

Solar System - Match the planets and information. 

Sorting - Sort the items. Many possibilities. 

Spot the Dog - . Find my dog. He's the one with the red collar. 

Story Builder - Build sentences from lists of words and phrases. 

Teddy - The classic My World screen updated. Dress the bear. 

Tiles - Investigate tiling, symmetry and tessellation with this versatile screen. 

Traffic - Match vehicle names and pictures in French, German and Spanish. 

Words - Sentence starts and finishes. 

World Map - Put words and symbols on the map. 

Not appearing on the opening menu screens are three 'template' screens which you can use as starting points for building your own screens.

Access them by choosing Open form the File menu. (By default, My World screens open in full screen mode. To access the menus, press the Tab key)

Basis1 - blank screen with text and bin icons 
Basis2 - blank screen with numbers, operators, text and bin icons 
Basis3 - blank screen with letter tiles, text and bin icons 
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What is My World?

My World is a popular, award winning educational software resource. Its concept is simple, but it has proved to be one of the most widely used programs in UK education.
 
My World screens can contain pictures and text. Pictures and text can be picked up, moved, dropped and deleted. Text can be added and edited. 

The program is very simple to learn and use, yet is powerful enough to be a most effective learning tool. 

My World is a valuable learning tool at home as well as in school. The range of screens makes it accessible to a wide spectrum of children, from pre-school to high school. 

_______________________________________________________________

Using the Browser 

The My World browser 'plays' existing My World screens. You can use screens made for older versions of My World as well as those made for My World 3.

You can change the screen by moving, adding and deleting objects. You can add, edit and delete text. You can save the edited screen under a new name. 

Please Note that if you save a screen from an older version, it becomes a My World 3 screen, and will no longer work in the older version.

_______________________________________________________________

Fullscreen and desktop modes

Some users find it easier to work without the distraction of the normal window "furniture". You can use the View menu (or press Ctrl/F) to switch to Fullscreen mode.

In fullscreen mode, the My World screen expands to fill the entire screen area. You can choose (from the Configure option in the Options menu) between filling the screen entirely and leaving a small menu bar visible at the top. 

Press the Alt key to toggle between revealing and hiding the menu bar.
Use the View menu (or press Ctrl/F) to switch back to Desktop mode.


Loading Screens

There are several ways to open a screen. 

(1)	Run My World 3 by double-clicking on the program icon. By default, this will open a menu screen, giving access to the example screens included with the program.
(2)	
If you wish, you can use the Configure option in the Options menu to open a directory rather than a screen.

Setting Start up with to C:\Program Files\MyWorld3\Screens\ will open an Open My World file dialog box. 

Click on Example screens to see the files shipped with My World 3.

Click on My screens to go to your own work space.

NB these directories are configurable in the Configure dialog box.

Choose a screen from the list by clicking on it then click Open, or simply double-click on the screen in the list.

2) If you are already running My World, click on the File menu then select Open. 

An Open My World file dialog box opens. Choose a screen from the list by clicking on it then click Open, or simply double-click on the screen in the list.

3) You can open a directory containing My World screens, then double-click on a screen name. 

The screen will then open.

_______________________________________________________________

Moving Objects 

Some objects on a screen may be moveable. They can be picked up with the mouse and put down in other places.

By default, My World 3 uses "button up dragging". Click once on a moveable object and it becomes "attached" to the mouse pointer. Click once more to put it down.

Touch screen users may wish to use "button down" dragging. This can be selected from the Configure option in the Options menu.

_______________________________________________________________

Copying Objects 

Some objects on a screen may be copiable. They cannot be moved, but clicking on them produces a moveable copy.

This copy is "attached" to the mouse pointer until you click once to put it down. 

NB. Copies are moveable objects - you can't make copies of copies.


Removing Objects

Most My World screens have a bin. (Its appearance may change from screen to screen)

Any moveable object can be removed from the screen by picking it up and placing the mouse pointer over the bin, then clicking once. 

NB. Removing an object from the screen cannot be undone.

_______________________________________________________________

Rotating objects 

Some screens have buttons which allow you to rotate objects. (The appearance of the icons may change from screen to screen) 

Any moveable object can be rotated by picking it up and placing the mouse pointer over a rotate button, then clicking.

When you have nothing attached to the mouse pointer, click on a rotate button to open a dialog box which allows you to change the amount and direction of rotation.

NB text cannot be rotated.

_______________________________________________________________

Changing the size of objects 

Some screens have buttons which allow you to make objects bigger or smaller. (The appearance of the icons may change from screen to screen)
 
Any moveable object or text object can be scaled by picking it up and placing the mouse pointer over a scale button, then clicking.

When you have nothing attached to the mouse pointer, click on a scale button to open a dialog box which allows you to change the amount of scaling up or down.

_______________________________________________________________

"Flipping" objects 

Some screens have buttons which allow you to "flip" moveable objects. (Their appearance may change from screen to screen)

Any moveable object can be flipped by picking it up and placing the mouse pointer over a flip button, then clicking. The flip can be either horizontal or vertical. Flip buttons have no dialog box.

NB text cannot be flipped.


Popups 

Some My World screens have a lot of resources available - too many to display on a single screen.
 
These screens use popups. Popups are windows where extra resources can be stored. 

Resources in a popup can be picked up and placed on the main screen.
 
Some popups open automatically when you load the screen. 

Others open when you click a button.
_______________________________________________________________

Adding and editing text

Some screens have buttons which allow you to add and edit text. (The appearance of the icon may change from screen to screen)

Click on the text icon to open a dialog box. Here you can type in your text and set its size, colour and font.

NB. In My World 3, you can enter several lines of text. 

Press Enter to start a new line. 

Press OK to add your text to the screen. It will be "attached" to the mouse pointer. Click once to put it down.

A text object can be edited by picking it up and moving the mouse pointer over the text button. Clicking once will open the text dialog box with the text to be edited in it.

_______________________________________________________________

Printing the screen

Some screens have buttons which, when clicked, will print the screen.
You can also select Print from the File menu on any screen.

In either case, a Print dialog box will open, allowing you to choose from the range of print options.

_______________________________________________________________

Options 

The My World browser has four menu options.

The File menu allows you to Open, Save and Print screens and to Exit My World 3.

The View menu (or Ctrl/F) allows you to turn the Fullscreen option on and off. When Fullscreen is selected, the screen expands to fill the entire screen area. Press the Alt key to show or hide a menu bar at the top of the screen.

Home takes you back to the first screen opened in the current session of using My World, or a page that has a SetHome command.

The Options menu has three options.

Grid allows the user to change the appearance and behaviour of the screen's grid.

Show makes the grid visible. Lock makes moveable objects 'snap' to the nearest grid point.

There are three grid modes. Rectangular and Isometric control the pattern of the grid points.

When Magnetic Search is enabled, any moveable object will 'snap' to the nearest object within the configured distance when dropped.

All units in this dialog box are in inches.

Spacing and Sub-Divisions control the distance between Rectangular and Isometric grid points.

Configure is used to change the program's settings. 

Authorised users can change these by selecting the Configure... option and entering a password.
For details of the Configure options, please see the next section.

Editor Mode 

Swaps into Editor Mode once the Configure option has been set.

The Help menu gives access to the Help file and to current version details. For latest information and Frequently Asked Questions, visit www.dialsolutions.com.

Saving screens
To save a screen, select Save from the File menu.

Note My World 3 saves the screen, its resources and all popups and linked files in a single file. This makes it 'network-friendly' - screens can be saved to any directory and still work correctly when reloaded.
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Getting Started

Unlike previous versions, My World 3 has its own editor. 

If your copy of My World starts up in browser-only mode, you will need to access Configure in the Options menu to gain access to the editor.

Enter the password (by default this is MW3 (case sensitive)). A Configure dialog box opens.

This allows you to configure the program:

1) You can configure the Example screens and My Screens directories from this dialog box.

Example screens - normally the directory containing the example screens shipped with My World 3.

My screens can be configured to point at the user's own work space.

2) Start up with allows you to choose which screen or directory will be opened when you run My World 3.

3) For access to the Editor click the Allow access to Editor from Browser. (To restrict access to the browser only, untick the box).

The Editor option is now available from the Options menu.

To return to browser mode, select Run from the File menu.

Click on the Options menu again. You will see that Editor mode is no longer greyed out. Click on this option. The menus at the top of the screen change.


Making a simple screen

To make a simple My World screen, begin by clicking on New on the File menu.

A blank screen opens.

Double click anywhere on the screen area. A Frame Properties dialog box appears.

Frame Properties dialog boxes are used to control the behaviour of all the resources (text, images, animations etc.) that you add to your screen.

Frame 1, the backdrop, which you have just clicked on almost always needs to be set to be a Dropzone, ie to allow other objects to be placed on top of it in browser mode. By default, the backdrop is transparent. See the note on Receives events below.

Click on the arrow in the Frame Type combo box and look down the list for Dropzone. Click on it, then click OK.

(For more details of frame types see the separate entry on the Menu screen).

Note the Always on top and Receives events tickboxes.

Always on top is normally used for buttons (text, bin, rotate, scale etc.) so that when you drag a resource to them the buttons remain visible, making it easy to correctly position the mouse pointer over the button itself.

Receives events changes the way in which transparency is handled. 

All resources are contained in a rectangular frame. Many graphics however have an irregular shape, and parts of the area of the bounding box are therefore transparent. In a screen like Teddy for example, it is important that the transparent areas are ignored, allowing you to pick up a garment partially overlaid by another.

In some cases however, it is necessary for a frame to respond to a click anywhere within its bounding box.

Text can be difficult to pick up, so by default all text frames have Receives events ticked.

Screens like Face and Body use transparent frames (create these by choosing the New blank option from the Frame menu). The frames cover part of the picture, and are programmed to play a sound when they are clicked on.

Backdrops, by default, are transparent (but appear white on the screen). You should therefore use the Background colour option in the dialog box to set a colour or click in the Receives Events tickbox.

The objects which you place on the screen (images, text, animation, etc.) are called resources. 

There are a number of ways to add resources to a screen. 

The simplest way to add graphics is to drag and drop a file icon onto the screen from any filer window. (In the My World 3 directory you will find a directory called Resources. This includes many graphics for you to experiment with.) 

Each resource is held in a rectangular frame which is normally invisible. (To see frames, click the View menu and select Show borders).

You will need to set the frame type for each resource. Double-click on a frame to open the Frame Properties dialog box.
On a simple screen, the two frame types you are most likely to use are Moveable and Copiable. Click the Frame Types menu arrow, scroll down the list, click on the frame type then click OK.

You can also add a resource to the screen by clicking on the Frame menu and selecting New.

A dialog box opens. This allows you to move to any directory (such as Resources in the My World 3 directory), select a resource then click Open. 

The resource will appear on the screen, surrounded by a red border as it is now the selected resource. Double-click on it to set the frame type.

You can also add resources from the Resources viewer. Select Resources from the View men. If the resource is already stored in the My World file, you can drag its icon into the main screen. The resource appears there.

You can also use the Resources viewer to store resources to be added to the screen later. Drag file icons from directory viewers (eg the Resources directory inside the My World 3 directory) into the viewer. 
If they are to be used in one screen only, drag them to that screens icon. If they are to be shared by several screens, drag them to the Shared directory.

NB also see the section on editing frames.

Arranging resources

In the editor, you can move resources by clicking on them then dragging them. 

Testing the screen

Once you have added some resources and set their frame types, you will probably want to check that the screen works.

To do this, you need to return to browser mode.

It is advisable to save your screen first. From the File menu, select Save. If this is the first time you are saving your screen, you will be prompted for a filename.

Now from the File menu, select Run. The screen is now in browser mode, and you can check that it works as you expected.

Troubleshooting

Symptom: can't put objects down on the screen.
Reason: the backdrop frame type is not set to Dropzone and/or the Receives events box has not been ticked.

Adding Text

To add text to the screen, click on the New Text option in the Frame menu.

A text dialog box opens. 

My World 3 allows multi-line text. Press Enter to start a new line.

You can choose the colour and font style of your text, and see these in the dialog box.

NB you cannot change colour or style in the middle of a piece of text.

Enter your text, then click on OK. The text appears on your screen.

Adding buttons

Buttons are resources whose frame types make them act in a special way.

The two buttons most commonly used are Text and Bin.

To make a button, first import a suitable graphic (or create some text). Double click on the graphic or text to show the Frame Properties dialog box, then select the required function (eg Bin.mwb or TextButton20Pt.mwb) from the drop down menu.

When you click on a resource set to be a TextButton in browser mode, a text dialog box opens .
Use this to create new text. You can also pick up existing text and drop it on a TextButton to edit it.

Any moveable object or text object can be removed from the screen by picking it up and placing the mouse pointer over the Bin, then clicking once. 

NB. Removing an object from the screen cannot be undone.

For details of the functions of other buttons, see the Using the My World Browser section.

You should now be able to make a single screen which includes moveable and copiable objects, text and buttons.



Making popups

One of the most useful features of My World is popup windows.

Popups are additional windows which can hold resources and tools. 

Resources in the popup can be picked up and placed on the main screen.

Resources on the main screen can be picked up and brought to buttons in the popup.

(Examples - look at Chart or City in the example screens)

To make a popup, select New from the Screen menu.

Give your popup a name and click OK.

The popup opens on top of the existing screen. By default, it is the same size as the screen.

You can adjust the size of the popup window by double clicking on the backdrop to open the Frame Properties dialog box then editing the numbers in the width and height boxes.

Drag the popup window to the position where you want it to appear.

You must set the frametype of the popup backdrop, as you did for the main screen.

A suitable frametype is PopupTitleOnly, which removes the window furniture from the popup's title bar.

Doubleclick on the popup's backdrop, then choose from the Frame Types menu. 

You now need to make the popup open on command. To do this, you will need to add a script file to the main screen.

Script files

You have already seen that frames can be set to Copiable, Moveable etc.

This process is controlled by a script language. 

The Frame Types menu is a set of pre-defined frame types stored in a global resources directory inside My World which cannot be altered (if you did so, screens made by other authors would be affected). 

However, you can copy these script files to a screen's local directory and edit them.

You can see the range of available frame type scripts by selecting Mwb files from the View menu.

To open a popup when the main screen opens, you can set the main screen's backdrop to Dropzone1.mwb.

Like all .mwb script files, this is a plain text file. You can open it in any text editor, such as Notepad.
Please take a moment to do this, and to look at the structure of the file.

The Dropzone1.mwb file contains a number of comments (lines beginning REM) which have no effect on its working.


The actual commands are contained in two procedures:

DEFPROCOnOpen
PLAY("This")
REM Open("2")
ENDPROC

DEFPROCOnDrop
REM allow other objects to be placed on top of this one
REM change the owner of the frame belonging to the pointer
REM to be the main screen
Sound(PATHGLOBALSHARED$+"Drop.wav",1,ASYNC%)
FrameChangeOwner("Pointer")
ENDPROC

PROCOnOpen opens the popup if you delete the REM from its second line.
 
(NB the popup name MUST match that in the mwb file - in this case 2 - any other name will cause an error)

PROCOnDrop makes the background frame a dropzone, so that other files can be dropped on it in browser mode.

You now need to make the Dropzone1.mwb file accessible to the main screen.

To do this, select Resources from the View menu. A resource viewer opens:

The viewer shows screen 1 (the main screen) and a Shared directory, which all My World 3 files have.

You can now drag the Dropzone1.mwb file into the screen 1 area of the viewer (ie on the icon labelled 1) from the Mwb files window.

Double click on the backdrop of the main screen. Go to the top of the Frame Types menu and find
PATHSCREEN$+Dropzone1.mwb. Click on this, then on OK.

Save the screen then select File -> Run

If you selected PopupTitleOnly for the backdrop of the popup, you will notice that all the window furniture except the title bar has been removed. 

The popup can be moved around the screen.

To close it, you will need to add an icon (CloseButton.gif in the My World3\Resources directory, for example). Set the icon's frame type to CloseButton.mwb

You therefore need a way of re-opening the popup if it is needed again.

A simple way of doing this is to start a new text frame (see above) and enter text such as 'open popup' then to set its frame type to (Popup2.mwb).

The key part of this is a single procedure:

DEFPROCOnClick
Open("2")
ENDPROC

Double click on the text frame you made. In the list of frametypes, find the item 
PATHSCREEN$+Popup2.mwb

Click on this, then on OK. Save your screen then run it. You should be able to close the popup then re-open it by clicking on the text.

(Please note again that the filename of your popup MUST match that in the script file.

So if you want to open a popup with another name, copy the Popup2.mwb file icon from the Mwb Files directory into the screen 1 area of the resource viewer, edit the popup name then set the frame type of the text or icon which will open the new popup.

If you need to open several popups, you can of course save Popup2.mwb under other names in the Resources Viewer)

_______________________________________________________________

Making Linked Screens 

The example files contain many sets of linked screens, eg Chart.myw, Number Bonds.myw and Traffic.myw

Linked screens are created in the same way as popups, but it is not normally necessary to resize the screen.

Screens names can be numbers or words (but NB, the first screen MUST always be called 1).

As with popups, you will need to add local script files to link to and from the different screens you create.
The Mwb files directory contains an example (OpenLink.mwb) of a link from screen 1 to a linked screen:

DEFPROCOnClick
REM Open a new screen
OPEN("10")
REM Close the current one
CLOSE("This")
ENDPROC

NB 1) the screen name MUST match that in the script file

2) it is important that the OPEN command is placed before the CLOSE command in the script.

This script is designed to be used with a text or graphics frame. When the picture or words are clicked on, the linked screen opens and the current one closes.

Once you have made a link to another screen, you need a way of returning to screen 1.

If your linked screen has no popups, you can use the LinkTo1.mwb file in the global resources directory (but remember that you cannot edit this. This simply closes the current screen and opens screen 1.

If, however, you have one or more popups on your linked screen, you will need a local file which closes any of these which are open as well as the screen, before returning you to screen 1.

The Mwb files directory contains a copy of LinkTo1.mwb which you can edit and copy to 

DEFPROCOnClick
REM Open a new screen
OPEN("1")
REM Close the current one
CLOSE("This")
ENDPROC

If your screen has any popups, you can close them automatically by adding one or more commands like this:

CLOSE("popup1") before the ENDPROC line 
(You can add lines to close all your popups, whether currently open or not)

This script will now close the linked screen and a popup called 'popup1'.
It then opens screen 1.

NB unlike previous versions of My World, the state of the link screens is 'remembered' until the whole file is closed. This allows you to make changes to one screen, go to another then return, to find your changes unaffected.
_______________________________________________________________

Frame Types 

The Frame Properties dialog box (accessed in Editor mode by double clicking on a frame or by single clicking then selecting Properties from the Frame menu) has a list of globally shared frame types. These are also available in the MWB files directory. 

You can import Mwb files from there to your screen's Resource Viewer, so that they become available locally. You can then edit the local copy.

AnimationPause.mwb - Plays an animation when the screen opens. When you click on it, the animation pauses. 
AnimationPlay.mwb - Plays an animation when the screen opens. When you click on it, a paused animation restarts. 
Bin.mwb - Deletes other moveable resources. Pick up the resource to be deleted, move it over the bin and click once. This operation cannot be undone. 
CloseButton.mwb - Closes the current window. Particularly useful for closing popups. 
Copiable.mwb - Makes an object copiable. The original cannot be moved, but unlimited numbers of moveable copies can be made by clicking on it. 
DropZone.mwb - Allows other objects to be dropped on top of it. This will almost always be the frame type of a screen backdrop. 
DropZone1.mwb - Sets up a dropzone. PROCOnOpen includes a line which will open a popup. 
ExternalLink.mwb - Links to a My World file outside the current 'book'. Menu1.myw and Menu2.myw in the examples use this command. 
FlipX.mwb - Flips other moveable resources horizontally. Pick up the resource to be flipped, drag it over the flip button and click once. 
FlipY.mwb - Flips other moveable resources vertically. Pick up the resource to be flipped, drag it over the flip button and click once. 
GoHome.mwb - Closes the current screen and opens the one currently designated as Home (see SetHome in the Script Language section). 
LinkTo1.mwb - In a set of linked screens, closes the current screen and opens screen 1. 
Moveable.mwb - Makes the resource moveable. 
OpenLink.mwb - In a set of linked screens, open another screen and close the current one. 
PlaySound.mwb - frame plays a .wav file when clicked on. 
Popup2.mwb - Opens a popup. 
PopupTitleOnly.mwb - Sets the background style of a popup. Removes the Close icon and scroll bars. 
PrintAllFit.mwb - When clicked on, prints the screen. 
RotateAcw.mwb - Rotates other resources anticlockwise.Pick up a moveable resource and drag it so that the mouse pointer is over the Rotate button, then click once. Right click on the Rotate button to open a dialog box allowing you to change the amount of rotation. 
RotateCw.mwb - Rotates other resources clockwise.Pick up a moveable resource and drag it so that the mouse pointer is over the Rotate button, then click once. Right click on the Rotate button to open a dialog box allowing you to change the amount of rotation. 
RunExternal.mwb - This will run a file associated with another program stored in a directory outside the current screen's directory. 
RunInternal.mwb - This will run a file associated with another program stored in a directory inside the current screen's directory. 
ScaleDown.mwb - Scales other resources down. Pick up a moveable resource and drag it so that the mouse pointer is over the Scale Down button, then click once. Right click on the Scale Down button to open a dialog box allowing you to change the amount of scaling. 
ScaleUp.mwb - Scales other resources up. Pick up a moveable resource and drag it so that the mouse pointer is over the Scale Up button, then click once. Right click on the Scale Up button to open a dialog box allowing you to change the amount of scaling. 
ScaleXY.mwb - Allows separate scaling of the X and Y axes of a resource. 
SetHome.mwb - Used to make the screen the current Home page (press Home on the keyboard to activate this). 
TextButton20Pt.mwb - Opens a text dialog box, set to 20 point Comic Sans MS font. 
TextButton24Pt.mwb - Opens a text dialog box, set to 24 point Comic Sans MS font. 
TextButton32Pt .mwb - Opens a text dialog box, set to 32 point Comic Sans MS font. 
_______________________________________________________________

The Run command (Running files in other programs)

My World has a Run command which will start another program on your computer and run a specified file.

To do this, you need to include an MWB file in your screen. 

Two examples are given below:

DEFPROCONCLick
Run(PATHSCREEN$+"canary1.mpg")
ENDPROC

This runs a file stored in the current My World screen directory 
(Run(PATHBOOKSHARED$+"canary1.mpg") would run a file stored in the Shared directory).

DEFPROCONCLick
Run("C:\edward.doc")
ENDPROC

This runs a file stored elsewhere on your computer or network. 

Notes for screen designers:

You must supply a full pathname for an external file, though this can include My World variables such as FILEBOOK$.

Run(FILEBOOK$+"..\Example.doc") would run a file saved in the same directory as the My World file.
This command will only work with filetypes associated with programs already installed on the computer or network.

Sound Files 

Any frame can be set to play a .wav format sound file when clicked on.

A suitable .mwb script file (PlaySound.mwb) is included in the Mwb files directory.

The script reads:

DEFPROCOnClick
REM Store your sound in the Shared directory of the My World file
REM Access this via the View->Resources menu
REM Sound must be a wav file. Edit the name of the file as necessary
Sound(PATHBOOKSHARED$+"sound.wav",1,ASYNC%)
REM FrameChangeOwner("This")
ENDPROC

NB the file also includes a procedure OnDrop. This allows other resources to be placed on top of the frame.

Note also that the .wav file must be stored in the My World file's Shared directory, accessed via the Resources option of the View menu.

_______________________________________________________________


Editing Graphics Frames 

Graphics frames can be edited in several ways. Make sure you are in Editor mode, then select the frame by clicking on it. A red border appears around it.

1) Double click on the selected frame to open the Frame Properties dialog box, which allows you to edit the frame:

a)	Use the Frame Type menu to change how the frame behaves.

b)	Use the Background Colour box to change the background.

NB by default, the background colour is set to None. Untick the box on the colour picker.

c) Use the Window Position icons to change the position and size of the frame.

NB Changing the size of bitmaps, gifs and animations will affect the quality of the image.

2) You can resize a frame by dragging its sides and corners.

3) You can edit the contents of a graphics frame by opening the Resource viewer for the screen then double-clicking on the file icon. If a suitable editor is available, your file will be loaded into it. When you have edited the file, save it, then save the My World file. Re-open the My World file, and your changed file will appear.

Screen Mode

New My World screens open by default in desktop mode.

A screen in desktop mode has all the normal window furniture.

NB My World 3 works best in a screen resolution of 800 x 600 or higher.

If you select the Full Screen option in the View menu (or press Ctrl/F), the My World screen expands to fill the screen area. The Alt key toggles the menu bar on and off. Many of the example screens are configured to start in this way.

Click the menu option again (or press Ctrl/F) to return to the desktop view.

NB a screen will open in the mode in which it was last saved.

_______________________________________________________________

Zooming 

You can zoom in or out on a My World screen.

Zoom in can be useful when editing, allowing you to see details clearly.

Zoom out is used on some popups (eg in Egypt.myw in the example files) to reduce the size of the popup. When resources are dragged from the popup to the main window, they regain their normal size.

The View Menu has several options concerned with zooming:

Normal size - returns the screen to its original magnification (1:1).

Zoom In - doubles the current magnification.

Zoom Out - halves the current magnification.

Zoom Fit - resizes the screen to fit the current window.



Grids 

To access the grid dialog box, select the Options menu, then Grid.. 

You can set the grid to be visible and locked in the editor, in the browser or in both. The grid can be rectangular or isometric, and you can configure its spacing, subdivisions and colour. It is often helpful when making a screen to set the grid to be locked in both the editor and browser, but only visible in the editor.

An isometric grid is used in the 'FindTed' screen. 

When the grid is locked, moveable objects 'jump' from one grid point to the next as they are moved.

Ticking the Smooth Dragging option will cause moveable objects to snap to grid points only when they are placed back on the screen. 

The third grid option is 'magnetic snap'. 

Here, each moveable object is 'attracted' to another once it comes close to it, so that if you put it down in approximately the right place, it will jump to fit. 

This makes it easy in screens like 'Blocks' and 'Tiles' to fit shapes exactly together.

This is possible because the corners of each frame (and the vertices of vector files) have, by default 'magnetic points' attached to them. It is actually these points which snap together.

As you move the mouse pointer over a magnetic point in a selected frame, you will see it change to a + shape. You can now drag the point or, by right-clicking on a frame, you can bring up a menu allowing you to add and delete magnetic points.

Screens like 'Teddy.myw' in the example files are designed so that the clothes jump to the correct position if they are put approximately in the right place. 

The Teddy figure is a dropzone. All the clothes are moveable objects. 

To make the screen, all grid options were turned off and the Teddy and clothes frames were created in the editor. 

Once the frametypes were set, the clothes were placed in their intended final positions. 

The rectangular grid was then set to be locked in browser mode. Smooth Dragging was selected and the screen was saved. 

The screen was then run in browser mode, and the clothes were picked up and moved away from Teddy. The screen was saved again. 

Now the clothes can be picked up and moved about smoothly, but will snap to the nearest grid point when put down. 

This means that if you put them approximately in the right place, the clothes will jump to a 'correct' position.


Other Menu Options

View Menu

Show Resource Names - superimposes the filename of each resource on its frame

Debug Window - This option opens a window which shows where errors occur in mwb files by showing how far it got through the file when compiling it. 

Variables - shows the list of variables accessible to the currently selected frame. There are 3 sets of variables: 

1. Variables declared in the frame's script file which are accessible only by that frame, 
2. Variables automatically generated by My World which are accessible by all frames in the current screen, and 
3. Variables accessible by all frames in any screen. 

Resources - see the Adding Popups section

Screen Menu

Describe - opens a textfile which lists all the frames in the screen and details their attributes.

Frame Menu

Describe - opens a textfile which details the attributes of the selected frame.

Snap to grid - 'Snaps' the frame to the nearest point on the grid.

Scale 1:1 - enables you to restore a frame to its original size if you have resized it.

Move Forwards - moves the frame one level 'forwards' (ie in front of other resources).

Move Backwards - moves the frame one level 'backwards' (ie behind other resources).

Option Menu

Make resources local - stores all resources (except the globally shared .mwb and sound files) within the My World file.

_______________________________________________________________

Touch Screens

From Configure in the Options menu, you can enable button down dragging. This option is particularly useful for touchscreen users.

The Script Language

Please note:
This section is a reference guide to the My World 3 script language.
It is intended for the advanced editor, and will not concern most users.

NB throughout this section:

$ denotes a string of characters (letters and numbers)

% denotes an integer

& denotes a hexadecimal number

Frame behaviour is defined by what a frame does in response to an event that it receives.

Each frame can have a script file associated with it which lists what the frame must do in response to an event. When a frame receives an event, it calls a procedure whose name is directly related to the name of the event.

For example, if a frame receives a 'Foo' event then the script procedure called 'OnFoo' will be executed.

In this version of My World, a frame can only receive the following events:

"Load": all frames receive this event when a My World file is loaded
"UnLoad": all frames receive this event when a My World file is unloaded (i.e. when either another My World file is about to be loaded to replace the current one or if My World is about to exit).
"Open": all frames receive this event when the screen in which the frame belongs is opened.
"Close": all frames receive this event when the screen in which the frame belongs is closed.
"Click": the frame underneath the pointer receives this event when the left mouse button is clicked and there is no object being dragged.
"Drop": the frame underneath the pointer receives this event when the left mouse button is clicked and there is an object being dragged.

In the script file, a procedure to handle events is defined as follows:

DEFPROCOn<EventName>
<Statements>
ENDPROC

where <EventName> is one of the six event names (e.g. DEFPROCOnLoad)
and <Statements> is zero or more of any of the following:

CLOSE(ScreenName$)
Closes the given screen.

ScreenName$ is the name of the screen to close. Can be "THIS" to close the screen containing the frame which is processing the current event.

DBOXSETVARIABLE(Title$,Prompt$,HelpMessage$,Minimum,Maximum,VariableName)
Displays a dialog box enabling the user to set the value of a variable.

Title$ is a string which appears as the caption of the dialog box.
Prompt$ is a string which asks the user to enter an appropriate value (e.g. "Enter an angle").
HelpMessage$ is a string which provides more information (e.g. "Enter a negative number to rotate objects clockwise").
Minimum is a number which is the minimum permitted value for the variable to be set and is ignored if the variable to be set is a string.
Maximum is a number which is the maximum permitted value for the variable to be set and is ignored if the variable to be set is a string.
VariableName is the name of the variable to be set (e.g. Total, or Count%, or Name$)

FRAMECHANGEOWNER(FrameName$)
Changes the owner of the given frame.

When FrameName$ is "THIS" the frame processing the event is removed from its screen and becomes 'owned' by the pointer (i.e. moving the pointer drags this frame with it).
When FrameName$ is "POINTER" the frame being dragged is added to the screen which contains the frame processing the current event.
No other values are currently allowed.

FRAMECHANGETYPE(FrameName$,NewType$)
Changes the frame type of the given frame.

FrameName$ can be either "THIS" to indicate the frame processing the current event, or "POINTER" to indicate the frame currently being dragged.
No other values are currently allowed.
NewType$ is the file name of a script file (e.g.PATHGLOBALSHARED$+"Moveable.mwb")

FRAMECOPY
A copy of the frame processing the current event is made and attached to the pointer.

FRAMEDELETE(FrameName$)
Deletes the given frame.

When FrameName$ is "THIS", the frame processing the current event is deleted. In this case, no further processing of this event will be done.
When FrameName$ is "POINTER" the frame being dragged by the pointer will be deleted.
No other values are currently allowed.

GOHOME
Closes all open My World windows (unless the Home page is in the same book) and opens the 'Home' screen. 

The 'home' screen is either the last screen opened by the File->Open menu command (or by double-clicking on a .myw file), or, if further screens have been opened by a link, any screen referred to by a call to SETHOME.

MOVE(ScreenName$,Left%,Top%,Width%,Height%)
Sets the position and size of a given screen.

ScreenName$ is the name of the screen to be moved, and can be "THIS" to indicate the screen containing the frame processing the current event.
Left% and Top% are the screen coordinates of the top left of the window client area, and Width% and Height% are its width and height in pixels. The client area is that part of the window in which the screen is drawn, and does not include common window items such as menus and caption bars. If the supplied values would cause the window to be outside the screen area, then they are adjusted appropriately. 

OPEN(ScreenName$)
Opens the given screen.
If the screen is in a different file to the current one then all open My World windows are closed first. 

PAUSE(FrameName$)
Pauses the given frame.

FrameName$ can be either "THIS", for the frame processing the current event, or "POINTER" for the frame being dragged by the pointer. No other values are currently allowed.

This call will only have an effect if the resource in the frame is an animation and it is currently playing. 

PLAY(FrameName$)
Plays the given frame.

FrameName$ can be either "THIS", for the frame processing the current event, or "POINTER" for the frame being dragged by the pointer. No other values are currently allowed. 

PRINTFRAME(FrameID%,Scale,Show%)
Prints the given frame, and anything in it.

FrameID% is the ID of the frame to be printed. This number is shown in the caption bar of the Frame Properties dialog box for a particular frame.

Scale is the size at which the frame should be printed. Allowable values are: 0 (print as large as possible), or any number between 1 and 800 inclusive indicating the print scale as a percentage of full size (i.e. 50% means print at half size, and 200% means print at twice original size).
Show% indicates whether to display the Print dialog box or not. Setting this to zero will prevent the dialog box from being displayed, any other value will show it. Displaying the Print dialog box enables user to check what their print out will be like and to adjust the size before either printing it or cancelling the print. 

ROTATE(FrameName$,Angle)
Rotates a given frame by a given angle.

FrameName$ indicates which frame to rotate. The only currently allowable value is "POINTER" for the frame being dragged by the pointer. Angle is the angle by which to rotate the frame in degrees. A positive angle will rotate frames anti-clockwise, a negative value clockwise. 

RUN(Filename$)
Runs another program or loads and runs the specified file in another program.

SCALE(FrameName$,XScale,YScale)
Enlarges or reduces a given frame by a given scale factor.

FrameName$ indicates which frame to scale. The only currently allowable value is "POINTER" for the frame being dragged by the pointer.
XScale and YScale are the X and Y scale factors respectively. 

SCROLL(ScreenName$,XScroll,YScroll,Flag%)
Scrolls a given screen by a given amount.
ScreenName$ should specify the name of a screen which is already open.
XScroll and YScroll indicate the amount by which to scroll the window horizontally and vertically respectively.
Flag% indicates whether the scroll values are relative to the current scroll position or are absolute values. Only use Absolute% or Relative% as anything else will cause an absolute scroll.

SETGRID(ScreenName$,Colour%,XSpacing,YSpacing,XSubDivision,YSubDivision,Flags%,MagSearch)
Defines the grid setting for a given screen.
ScreenName$ is the name of the screen whose grid is being set.
Colour% specifies the grid colour. This will usually appear in the form &BBGGRR, where & indicates a hexadecimal value, and BB, GG, and RR indicate 2 digit hex values for the intensity of Blue, Green, and Red in the colour respectively.
XSpacing and YSpacing indicate the horizontal and vertical spacing between grid crosses and are specified in My World units (46080 units per inch).
XSubDivision and YSubDivision indicate how the grid is sub-divided between crosses.For example, a value of 2 means that a dot will be drawn midway between grid crosses, sub-dividing that part of the grid into 2 parts.
Flags% specifies the type of grid, and whether it is shown and/or locked. If bits 0 and 1 are clear then the grid is rectangular. If bit 0 is set then the grid is isometric. If bit 0 is clear and bit 1 is set then the grid is magnetic. If bit 2 is set then the grid is shown in editor mode. If bit 3 is set then the grid is locked in editor mode. If bit 4 is set then the grid is shown in browser mode. If bit 5 is set then the grid is locked in browser mode. If bit 6 is set then smooth dragging is turned on.
MagSearch is the maximum manhattan distance (in My World units, 46080 per inch) to snap magnetic points by. 

SETHOME(ScreenName$)
Sets the given screen to be the home screen.

If the screen to be set is in the current My World file then only the screen name is required. 
If the screen is in another file then the name should be in the form "FileName.myw#ScreenName". 
Also, if the file is not in the same directory as the current My World file then the path will need to be specified (e.g. "C:\OtherScreens\OtherFile.myw#1", or "..\OtherDir\OtherFile.myw#menu")

SETWINDOWSTYLE(ScreenName$,StyleName%,NewValue%)
Changes the window style of the given screen.

ScreenName$ specifies which window to change the style of, and can be "THIS" to indicate the screen containing the frame processing the current event.
StyleName% is the name of the style to be changed, and NewValue% is its new value with allowable values depending on the Style name.
Allowable values for StyleName% are:
HASCLOSEICON%: If NewValue% is 0 then the window will have no close button.
ALWAYSONTOP%: If NewValue% is non-0 then the window will become an on-top window.
HASMENU%: If NewValue% is 0 then the window will have no menu.
HASCAPTION%: If NewValue% is 0 then the window will have no caption bar.
Note that removing the caption bar will also remove the close button.
HASSIZEBORDER%: If NewValue% is 0 then the window will have no sizing border, meaning that its size cannot be changed by the user. 

SOUND(WavFileName$,Count%,Flag%)
Plays a given .wav sound file.

WavFileName$ is the name of the file to be played.
Count% should be the number of times to play the file, 0 meaning loop forever. At the moment, the only allowable value is 1.
Flag% specifies how to play the file, if the value is SYNC% then the file will be played synchronously otherwise it will be played asynchronously. 

STOP(FrameName$)
Stops a given frame from playing.

FrameName$ can be either "THIS", for the frame processing the current event, or "POINTER" for the frame being dragged by the pointer. No other values are currently allowed.
This call will only have an effect if the resource in the frame is an animation and it is currently playing. 

TEXTCREATE(Family$,Style$,Weight$,Size%,Colour%)
Displays the text editing dialog box and initialises its' settings as follows:
Family$ is a prioritised comma separated list of either font names or generic family names (sans-serif/serif/cursive/fantasy/monospace) e.g. "arial,helvetica,sans-serif"
Style$ is the font style and can be either "normal", "italic", or "oblique".
Weight$ is the font weight, and can be any one of the following: 
"normal", "bold", "100", "200", "300", "400", "500", "600", "700", "800", or "900", where "100" is very light and "900" is very bold.
Size% is the font size in My World units (46080 per inch, or 640ths of a point).
Colour% is the text colour. This will usually appear in the form &BBGGRR, where & indicates a hexadecimal value, and BB, GG, and RR indicate 2 digit hex values for the intensity of Blue, Green, and Red in the colour respectively.
When the OK button has been pressed, a text frame will be attached to the pointer, containing the text entered in the dialog box. 

TEXTEDIT
Displays the text editing dialog box. The dialog is initialised to whatever settings and text are contained in the text frame being dragged by the pointer.

When the OK button has been pressed, a text frame will be attached to the pointer, containing the text entered in the dialog box.
If CANCEL is pressed instead, the text frame being dragged by the pointer will remain unchanged. 

ZOOM(ScreenName$,XScale,YScale,Flag%)
Zooms in or out on a given screen by the given X and Y scale factors.

If Flag% is RELATIVE% then the scaling is relative to the current screen scale, otherwise it is absolute.


Editor Tutorial

This section is intended as a guide to making a new My World 3 screen. Much more information is available from the Editor Menu.

1)	From the Options menu, select Editor Mode. (You may need to enter the Configure password and set Access to Editor from Browser).

2)	From the File menu, select New.

3) A new blank My World 3 screen opens.

3)	Double click on the screen backdrop to open the Frame Properties dialog box. 

From the Frame Types menu, select Dropzone.mwb.

Either use the Background Colour menu to set a colour, or ensure that Receives Events is ticked. Click OK.

5) You can now add resources to the screen.

You can add graphics resources to the screen by:

Clicking on the Frame menu, selecting New then browsing for a file

Opening a directory with suitable files (.gif, .bmp, .jpg, Acorn drawfiles, sprites and Ace films) then dragging and dropping into the screen window.

Selecting Resources from the View menu to open the screen's Resources Viewer. Resources can be dragged and dropped into this. They (and any resources already imported by other methods) can be dragged and dropped from the Resources Viewer into the screen window.

NB A My World 3 file consists of a directory for each screen and a Shared directory. 

Resources used by only one screen can be stored in its own directory.

Resources shared by several screens can be stored in the Shared directory.

From the View menu, select Resources. You will see that if you click on directory 1 (the current screen), a list of the screen's resources appears.

These can be edited by loading them into a suitable editor. 

You can drag the file icons from the Resource Viewer to the screen.

Unwanted resources can be deleted.

As resources are added to the screen, it is advisable to double-click on each and to set the Frame Type for the resource. This determines how the graphic will behave when the screen is run in browser mode.

The two most commonly used frame types are Copiable.mwb and Moveable.mwb. Animations should be set to AnimationPlay.mwb. (see also the later section on buttons)

NB The files Screen.mwb and Screen.scr are not editable from the Resources Viewer.


Text

There are two ways to add text to your screen.

1)	From the Frame menu, select New Text.

A text dialog box appears. Type in your text, set the font size, style and colour if necessary and click OK.

NB, unlike previous versions, My World 3 allows multiline text.

2)	Add an icon, eg Text.aff from the MyWorld3\Resources\Clipart directory and set its frame type to TextButton20Pt.mwb.

From the File menu, select Run. Click on the text icon. The text dialog box appears.

Text placed on the screen can be picked up and dropped on the text icon if you need to edit it.
Save your screen to keep the changes you have made.

Sound

You can add sound to your screen.

There is a selection of sound samples in the MyWorld3\Resources\Sound directory.

Copy any sounds you wish to use into the screen's Shared directory, using the Resources Viewer.

The Mwb Files directory contains a file called PlaySound.mwb. Copy this to the screen directory.

Double click on the file to edit it. (This, like all .mwb files, is plain text, so can be edited in Notepad).

Change the name of the sound to be played from "sound.wav" to the name of the file you are using.
You can then set the frame type of a graphic or piece of text to PlaySound.mwb.

Face.myw and Body myw in the Examples screens use a variation on this. These screens have a graphic with 'hotspots' which play different sounds when clicked on.

This is done by selecting New Blank from the Frame menu. A blank, transparent frame is created and can be dragged to a suitable position on top of the graphic.

Like all graphics frames, it can be resized by dragging the sides and corners, or by changing the numbers in the Frame Properties dialog box.

If the blank frame is then set to PlaySound.mwb, it will appear when the file is run that you are clicking on part of the underlying graphic.

Any frame can be made to play a sound file.

Setting the frame type to PlaySound.mwb, edited to match a suitable .wav file, would cause a sound to be played when the frame is clicked on in browser mode.

Buttons

The functionality of the screen can be extended by adding buttons, that is icons which change the way that moveable objects behave.


You have already seen how to add a Text button.

In the same way, you can add graphics to the screen and set them to be buttons by selecting the appropriate frame type.

Removing Objects

Most My World screens have a bin. 

(Its appearance may change from screen to screen). Set its frame type to Bin.myw.

In the Browser, any moveable object can be removed from the screen by picking it up and placing the mouse pointer over the bin, then clicking once. 

In the Editor, to delete an object select it, then from the Frame menu select Delete (or press Ctrl/X). 
NB. Removing an object from the screen cannot be undone.

Rotating Objects

Some screens have buttons which allow you to rotate objects. 

(The appearance of the icons may change from screen to screen). Set the frame type to RotateACW.mwb or RotateCW.mwb

Any moveable object can be rotated by picking it up and placing the mouse pointer over a rotate button, then clicking.

When you have nothing attached to the mouse pointer, click on a rotate button to open a dialog box which allows you to change the amount and direction of rotation.

NB text cannot be rotated.

Changing the size of objects

Some screens have buttons which allow you to make objects bigger or smaller. 

(The appearance of the icons may change from screen to screen). Set their frame types to ScaleUp.mwb or ScaleDown.mwb.

Any moveable object or text object can be scaled by picking it up and placing the mouse pointer over a scale button, then clicking.

When you have nothing attached to the mouse pointer, click on a scale button to open a dialog box which allows you to change the amount of scaling up or down.

"Flipping" objects

Some screens have buttons which allow you to "flip" moveable objects. 

(Their appearance may change from screen to screen). Set their frame types to FlipX.mwb (horizontal flip) or FlipY.mwb (vertical flip).

Any moveable object can be flipped by picking it up and placing the mouse pointer over a flip button, then clicking. The flip will be either horizontal or vertical. Flip buttons have no dialog box.

NB text cannot be flipped.

Much more information on editing screens is available from the Editor Menu.
FAQs

What is new about My World 3?

My World 3 

-	has improved use of sound 

-	screens can include animations.

-	can include multiple line text 

-	includes its own editor, making it easy to create and edit new screens 

-	accepts more filetypes, including .bmp, .gif, .wav 

-	frame types can be edited and customised 

-	is 32 bit software and network friendly

-     has a progammable script language.

Can I use my old My World screens in My World 3?

Yes 

-	Screens from older versions (Acorn or PC) will automatically be converted to the new My World 3 format on loading into My World 3. 

-	They will then run as normal. 

-	Important Note If you save a screen from an older version, it will no longer run in that version, only in My World 3. 

-	You are advised to first make copies of your older screens if you wish to continue to use an older version. 

Can I make my own screens?

Yes.

-	The built in Editor makes it easy to do this. 
-	See the Editor section for details.

Can I use My World 3 over a network?

Yes

-	My World 3 screens can be used over a network. 

-	On saving, the screen and all its resources (popups, links etc.) are stored in a single file. 

-	Screens can therefore be saved in individual pupils' personal directories and maintain their functionality. 



